Order matching issue
Incident Report for BitMEX
Resolved
This incident has been resolved, and all our systems are working as usual.

We apologise for any inconvenience caused and remind our users that all funds have always remained safe.
Please contact Support with any further questions.
Posted May 19, 2023 - 07:00 UTC
Monitoring
We have implemented a fix for this issue and our trading APIs are now working as usual. We will continue to monitor the issue and we remind our users that all funds have remained safe at all times. If you experience any further issues, please contact Support
Posted May 19, 2023 - 05:05 UTC
Identified
We have identified the issue and are working on a fix. Order matching has resumed for most traders however some users may experience an increased number of rate limit errors. As a consequence, order matching may still be impacted and orders submitted may get rejected.

We will continue to monitor the issue, and we remind our users that all funds have remained safe at all times.
If you experience any further issues, please contact Support.
Posted May 19, 2023 - 04:45 UTC
Update
We are continuing to investigate this issue.
Posted May 19, 2023 - 04:29 UTC
Investigating
We are investigating an issue with our order matching. Some clients have reported delayed or incomplete order matching.

We are investigating the issue.

We remind our users that all funds are safe and we will update any progress on the issue here.

If you have further questions please contact Support.
Posted May 19, 2023 - 04:29 UTC
This incident affected: BitMEX.com (Trading Engine).