The order processing issue which affected some users between 15:25 UTC and 15:55 UTC has been resolved. We identified the root cause as a hardware issue on our underlying cloud provider. We apologise for any inconvenience this may have caused.
If you have any further questions, please contact Support.
Resolved
The order processing issue which affected some users between 15:25 UTC and 15:55 UTC has been resolved. We identified the root cause as a hardware issue on our underlying cloud provider. We apologise for any inconvenience this may have caused.
If you have any further questions, please contact Support.
Investigating
We’re aware of an issue with periodic delays in processing orders and are investigating urgently. A further update will be provided here ASAP. We apologise for any inconvenience.