BitMEX Frontend Issue
Incident Report for BitMEX
Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Mar 29, 2019 - 20:08 UTC
Investigating
We have identified a disfunction of the BitMEX website, preventing a small group of users from placing orders via the website. The API is left unaffected. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Mar 29, 2019 - 19:13 UTC
This incident affected: BitMEX.com (Web Frontend).