Websocket API with Incorrect Rate-Limits
Incident Report for BitMEX
Postmortem

At 21:09:00 UTC 25 June, we released an update to our API layer that inadvertently started to count WebSocket subscriptions to certain tables against the request rate limit that had otherwise been exempt. This update may have impacted customers who heavily utilise the WebSocket API. Once the issue was identified at 00:19 UTC 26 June, we immediately rolled back the update to bring systems back to normal.

We apologise for any inconvenience this may have caused. To read more about which subscriptions are exempt from the request rate limiter, see our previous blog post [https://blog.bitmex.com/update-to-our-realtime-apis-image-delivery/] for details.

Posted Jan 14, 2020 - 20:24 UTC

Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jun 26, 2019 - 00:19 UTC
Investigating
We have identified an issue where certain users of the websocket API issue may incorrectly have been rate-limited. We apologise for any inconvenience this may be causing. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jun 25, 2019 - 20:09 UTC
This incident affected: BitMEX.com (REST API).