Delayed Deposits and Withdrawals

Incident Report for BitMEX

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 08:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 08:41 UTC

Identified

We have identified the issue and are working to implement a fix.

We remind our customers that all funds are safe and deposits will be credited once this issue is resolved.​ Withdrawals are being processed and confirmations will be sent once the issue is resolved. We are working on implementing a fix and will provide any updates here.

If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Jun 24, 2025 - 08:35 UTC

Investigating

We have identified an issue that is preventing deposits crediting to accounts and confirmation of completed withdrawals from BitMEX.

We remind our customers that all funds are safe and deposits will be credited once this issue is resolved.​ Withdrawals are being processed and confirmations will be sent once the issue is resolved. We are working on implementing a fix and will provide any updates here.

If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Jun 24, 2025 - 08:34 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).