Investigating - Customer support via email unavailable

Incident Report for BitMEX

Resolved

The Customer Support email service has been restored. Thank you for your patience.
Posted Oct 07, 2022 - 11:08 UTC

Identified

Customer Support via email is currently unavailable. Our Customer Support team is available exclusively in the trollbox and Discord until the issue has been resolved. We apologise for any inconvenience and will post updates as needed.
Posted Oct 07, 2022 - 10:27 UTC
This incident affected: BitMEX.com (Web Frontend, Identity Verifications).