Investigating Temporary Trading Engine Downtime
Incident Report for BitMEX
Resolved
We’ve completed our investigation into the temporary interruption of orders between 09:20 and 09:28 UTC. We’ve resolved the root cause which related to order processing on one engine broker. We apologise for any inconvenience that was caused. If you have any questions, we’d be more than happy to help you via Support.
Posted Nov 01, 2021 - 10:42 UTC
Investigating
The Trading Engine experienced temporary interruption of orders between 09:20 to 09:28 UTC. Funds remain safe.

We apologise for any inconvenience this may have caused. We are continuing to investigate and will post again should any updates arise. If you have any further questions, please contact Support.
Posted Nov 01, 2021 - 09:37 UTC
This incident affected: BitMEX.com (Trading Engine).