Investigating

Incident Report for BitMEX

Resolved

Cloudflare has confirmed a fix has been implemented, and we believe the incident is resolved, and all our systems are working as usual.

We apologise for any inconvenience caused and we remind our users that all funds have remained safe at all times.

Please contact Support with any further questions.
Posted Nov 18, 2025 - 15:07 UTC

Monitoring

Cloudflare is seeing services recover, but customers may continue to observe higher-than-normal error rates as they continue remediation efforts.
Posted Nov 18, 2025 - 12:28 UTC

Investigating

Cloudflare is aware of, and investigating an issue which impacts multiple customers. More information is available at https://www.cloudflarestatus.com/.

We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Nov 18, 2025 - 12:10 UTC
This incident affected: Miscellaneous (Cloudflare (Tokyo, Japan)).