USDT Deposit Intermittent Delays
Incident Report for BitMEX
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 03:28 UTC
Monitoring
Deposit and withdrawal functionality remains operational however the USDT deposits experienced intermittent delays since 20:00 UTC. This resulted in some delays updating the USDT wallet balance for users. We have resolved the issue and are currently monitoring it; funds are safe and all other functions remain normal.
Posted Nov 30, 2021 - 22:40 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).