Slow BitMEX Rest API Responses
Incident Report for BitMEX
Postmortem

Between 05:40 and 07:11 UTC today, a subset of the requests to the BitMEX REST API experienced slow API responses and eventual API timeouts due to resource contention at the API layer. Upon detection via our internal alerting mechanisms we identified the cause and mitigated the immediate impact within a few minutes. There is currently no ongoing issue and there was no impact to the trading engine or user data during this time.

Fixes for the underlying root cause of the issue have been identified and are being worked on as a priority. We will follow up with another announcement once these are live. We have also increased the sensitivity of our system monitoring to detect and resolve potential similar issues much sooner. We apologise for any inconvenience this may have caused.

Posted Jan 15, 2020 - 00:40 UTC

Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Feb 08, 2019 - 07:11 UTC
Investigating
We have identified that a subset of the requests to the BitMEX REST API experienced slow API responses. We apologise for any inconvenience this may be causing. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Feb 08, 2019 - 05:40 UTC
This incident affected: BitMEX.com (REST API).