BitMEX Spot on Web is Down

Incident Report for BitMEX

Resolved

This incident has been resolved. All funds remained safe. Apologies for any inconvenience caused, and if you have any questions, please contact Support.
Posted Dec 25, 2022 - 11:55 UTC

Update

We are continuing to monitor the fix we have implemented. All funds are safe. If you have any questions in the meantime, please contact Support.
Posted Dec 25, 2022 - 07:19 UTC

Update

We are continuing to monitor the fix we have implemented. All funds remain safe. If you have any questions in the meantime, please contact Support.
Posted Dec 25, 2022 - 04:13 UTC

Monitoring

We’ve implemented a fix to this issue, and we’re continuing to keep a close eye on it. All funds are safe. Apologies for any inconvenience caused. If you have any questions in the meantime, please contact Support.
Posted Dec 25, 2022 - 02:52 UTC

Identified

We’ve identified the cause of this issue, and are currently implementing a fix. All funds remain safe. If you have any questions, please contact Support.
Posted Dec 25, 2022 - 02:33 UTC

Investigating

Web users are currently unable to access BitMEX Spot. We’re investigating the cause of this issue, and will implement a fix as soon as possible. All funds are safe and we apologise for any inconvenience caused. If you have any questions, please get in touch with Support.
Posted Dec 25, 2022 - 01:11 UTC
This incident affected: BitMEX.com (Web Frontend).