Issue Affecting Withdrawals on BitMEX
Incident Report for BitMEX
Resolved
We've successfully implemented a fix that affected withdrawals on BitMEX. Withdrawals on the platform are now being processed normally. We apologise for any inconvenience this issue may have caused. If you have any further questions, please contact Support.
Posted Sep 19, 2022 - 01:58 UTC
Monitoring
We're aware of an issue affecting withdrawals on the BitMEX platform, and we've implemented a fix. A further update will be provided ASAP. All funds are safe, and we apologise for any convenience caused.
Posted Sep 19, 2022 - 01:24 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).