Incident Update: Cloudfare Performance Issues in APAC
Incident Report for BitMEX
Resolved
We continued to monitor the network performance issues from Cloudflare but could not identify any further occurrences.
We are now closing this incident, reminding all users to contact Support if they have additional questions.
Posted May 31, 2023 - 10:01 UTC
Identified
Please note that at 07:32PM UTC on 31 May 2023, Cloudfare shared an update that they are currently investigating issues with network performance in the APAC region. They are working to analyse and mitigate this problem, with more updates to follow.

We would like to remind our users that all funds are safe. We are currently monitoring the situation and deploying any further fixes if need be. We will continue to provide our users with updates.

If you have any additional questions or are being impacted by this, please contact Support or your relevant Relationship Manager who will be able to assist.
Posted May 31, 2023 - 07:43 UTC
This incident affected: BitMEX.com (Web Frontend).