Withdrawal Confirmation Emails Not Sent / Withdrawals Not Executed
Incident Report for BitMEX
Resolved
This incident has been resolved and all our systems are working as usual.

We apologise for any inconvenience caused and we remind our users that all funds have remained safe at all times.

Please contact Support with any further questions.
Posted Feb 09, 2024 - 12:26 UTC
Monitoring
We have identified an issue that was affecting all withdrawal confirmation emails from being sent out to users.
As a consequence, users requesting withdrawals were unable to confirm the withdrawal and have it processed.

The issue persisted from 09:00 - 10:15 UTC and has been fixed now.

If you attempted to process a withdrawal during this time, you should re-request the withdrawal and confirm the email.

We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Feb 09, 2024 - 10:14 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).