Deposits and Withdrawals Not Processing
Incident Report for BitMEX
Resolved
This incident has been resolved and all our systems are working as usual.

We apologise for any inconvenience caused and we remind our users that all funds have remained safe at all times.

Please contact Support with any further questions.
Posted Sep 11, 2024 - 18:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 11, 2024 - 18:26 UTC
Investigating
We have identified an issue that is preventing deposits to and withdrawals from BitMEX to be processed.

We remind our customers that all funds are safe and deposits will be credited once this issue is resolved.​ We are working on implementing a fix and will provide any updates here.

If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Sep 11, 2024 - 17:09 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).