The maintenance is now complete, we are monitoring the upgraded systems.
Posted Dec 18, 2025 - 11:53 UTC
Update
We continue to work on the infrastructure.
We are now processing all non-Bitcoin Deposits and Withdrawals and continue to update the infrastructure for Bitcoin.
We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Dec 18, 2025 - 11:02 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 08:00 UTC
Scheduled
We are undertaking scheduled maintenance to our wallets infrastructure which will last approximately 3 hours commencing at 08:00 UTC on the 18th Dec 2025.
During this time withdrawals will not be processed and deposits will not be credited to customer accounts.
We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Dec 18, 2025 - 01:41 UTC
This scheduled maintenance affected: BitMEX.com (Deposits / Withdrawals).