Intermittent Connectivity Issues
Incident Report for BitMEX
Resolved
This incident has been resolved.
Posted Jul 02, 2024 - 10:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2024 - 10:07 UTC
Investigating
We are seeing intermittent issues with our API query service, some users report that the website is not loading properly. We are investigating the issue.
Posted Jul 02, 2024 - 09:49 UTC
This incident affected: BitMEX.com (REST API, Web Frontend).