Delayed Deposits and Withdrawals

Incident Report for BitMEX

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 09:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2025 - 09:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 11, 2025 - 09:10 UTC

Identified

We have identified an issue that is preventing deposits to and withdrawals from BitMEX to be processed.

We remind our customers that all funds are safe and deposits will be credited once this issue is resolved.​ We are working on implementing a fix and will provide any updates here.

If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Feb 11, 2025 - 09:03 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).