Processing of Deposits & Withdrawals delayed
Incident Report for BitMEX
Resolved
This incident has been resolved and all our systems are working as usual. Pending deposits and withdrawals have been processed, however, selected withdrawal confirmation requests may have expired, and you need to re-initiate the withdrawal via www.bitmex.com/wallet.

We apologise for any inconvenience caused and remind our users that all funds have always remained safe.
Please contact Support with any further questions.
Posted May 12, 2023 - 13:06 UTC
Identified
We are experiencing delays with the processing of deposits and withdrawal due to issues with the transaction infrastructure.

All funds are safe and the issue has been identified and a fix is being implemented.
The daily 13:00 UTC withdrawal processing of BTC is not impacted.

For more information please contact support@bitmex.com
Posted May 12, 2023 - 11:48 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).