BitMEX Homepage Temporarily Unavailable; Trading Unaffected

Incident Report for BitMEX

Resolved

This incident has been resolved and the homepage is available; while all trading via app, Websocket, and API was available throughout. We thank you for your patience.
Posted May 21, 2022 - 19:04 UTC

Investigating

We are aware of the BitMEX.com homepage website being unavailable for users, though all trading via the BitMEX.com/app, Websocket, and API services remains available. While we implement a fix, we ask that all users access trading via app, Websocket, or API as normal. We will share an update about the homepage shortly and apologise for any inconvenience caused.
Posted May 21, 2022 - 18:40 UTC
This incident affected: BitMEX.com (Web Frontend).