WebSocket API Degradation
Incident Report for BitMEX
Postmortem

At 02:44:10 UTC the WebSocket API saw a degradation in performance for a minute where 7% of commands sent by clients failed. Connections continued undergoing a 1% failure rate of commands until servers recovered at 02:47:00 UTC.

Clients may have also seen an increase in response times for some market data REST endpoints up during this period. This was due to a rolling restart of the API servers that occurred in too tight of a timeframe.

Posted Jan 15, 2020 - 01:13 UTC

Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jan 09, 2019 - 02:47 UTC
Investigating
We have identified a WebSocket API degradation in performance issue. We apologise for any inconvenience this may be causing. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jan 09, 2019 - 02:44 UTC
This incident affected: BitMEX.com (REST API).