KYC Unavailable for bitmex.hk mobile app users
Incident Report for BitMEX
Resolved
This incident has been resolved.
Posted Jan 22, 2024 - 12:07 UTC
Identified
We have identified what’s causing this issue and we are already implementing a fix. We remind our users that all funds are safe and that they can contact Support with additional questions. We will publish updates as needed.
Posted Jan 22, 2024 - 11:56 UTC
Investigating
We have identified an issue that is preventing users of the BitMEX HK Mobile application from completing KYC. We are working on implementing a fix and will publish updates as necessary. We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support.
Posted Jan 22, 2024 - 11:50 UTC
This incident affected: bitmex.hk (Mobile App).