Distruption to Onboarding verification check
Incident Report for BitMEX
Resolved
This incident has been resolved.
Posted Feb 09, 2023 - 11:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2023 - 11:17 UTC
Update
The problem has been identified and we are working on a fix
Posted Feb 09, 2023 - 11:00 UTC
Identified
We have identified an issue that is stopping new users from completing the verification check. We are communicating with our Identity Verification partners to resolve this issue.
Posted Feb 09, 2023 - 07:58 UTC
This incident affected: BitMEX.com (Identity Verifications).