Investigating frontend login issues
Incident Report for BitMEX
Resolved
This incident has been resolved.
Posted Sep 17, 2024 - 19:17 UTC
Investigating
We have identified an issue that is preventing some users from logging in through the frontend.

We are working on implementing a fix and will publish updates as necessary.

We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Sep 17, 2024 - 18:57 UTC
This incident affected: BitMEX.com (Web Frontend).