Discrepancy in 'Available Balance' Display after Redeeming EARN
Incident Report for BitMEX
Resolved
We have resolved this issue - please reach out to Support with any questions.
Posted Dec 22, 2021 - 06:13 UTC
Investigating
We are aware of an issue affecting a small number of users whereby the Wallet Available Balance does not properly reflect the balance reflected in Transaction History after redeeming EARN. Funds are safe and we are working to implement a fix so that the Wallet Available Balance is accurate. We'll share updates here shortly and ask that you please contact Support should you have any questions; we will be happy to help.
Posted Dec 22, 2021 - 03:50 UTC
This incident affected: BitMEX.com (Web Frontend).