Websocket API Interruption
Incident Report for BitMEX
Postmortem

Between 10:44:13 and 10:52:29 UTC on 24 July 2019, the realtime data on the following websocket API feeds was interrupted:

account, affiliate, execution, funds, instrument, margin, order, position, trade, transact, wallet

Users of the BitMEX website may have noticed that some data was not updating during this period; e.g. in the Recent Trades panel, Open Orders panel, Fills panel, and Position panel.

The following public feeds were unaffected during this period:

funding, insurance, liquidation, settlement, impactQuote, impactQuoteBin1m, quote, quoteBin1m, quoteBin5m, quoteBin1h, quoteBin1d, tradeBin1m, tradeBin5m, tradeBin1h, tradeBin1d, orderBookL2_25, orderBook10, orderBookL2 The REST API was also unaffected and client-side data loss due to missed feed updates during this period can be resolved using the REST API.

During this period we continued to process all order instructions and the trading engine was unaffected. The outage was due to a slow consuming internal market data service which became degraded, putting pressure on our market data infrastructure. This internal market data service has been suspended whilst the root cause is being investigated. Additionally, several safety mechanisms are currently being deployed to prevent a potential recurrence from impacting user-facing feeds.

Posted Jan 14, 2020 - 20:14 UTC

Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jul 27, 2019 - 19:13 UTC
Investigating
We are observing an interruption in several feeds of websocket API. We apologise for any inconvenience this may be causing. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Jul 27, 2019 - 19:12 UTC
This incident affected: BitMEX.com (REST API).