Investigating
Incident Report for BitMEX
Resolved
The incident has been resolved and all pending withdrawals have now been cleared.
Posted Aug 19, 2024 - 10:02 UTC
Update
Deposits are now flwoing as expected and we continue to work through pending withdrawals, your patience is appreciated.
Posted Aug 19, 2024 - 09:17 UTC
Update
Pending deposits have now been cleared and we are working through pending withdrawals.
Posted Aug 19, 2024 - 08:12 UTC
Monitoring
We have implemented a fix for this issue and are working through the backlog of requests. We appreciate your patience.

We will continue to monitor the issue and we remind our users that all funds have remained safe at all times.
If you experience any further issues, please contact Support: https://www.bitmex.com/contact
Posted Aug 19, 2024 - 06:57 UTC
Investigating
We have identified an issue that is affecting deposit and withdrawal requests, preventing transactions being processed in a timely manner.

We are working on implementing a fix and will publish updates as necessary.

We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Aug 19, 2024 - 06:15 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).