Wallet page is not accessible from Web + Deposits & Withdrawals are being queued
Incident Report for BitMEX
Resolved
We have implemented a fix to this issue, and all withdrawals are processing as normal. Deposits and all Bitcoin withdrawals were never affected, and all funds remained safe at all times. Sorry for the inconvenience caused and please contact Support if you have any questions.
Posted Nov 11, 2022 - 03:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 11, 2022 - 03:47 UTC
Update
We have implemented a fix to this issue, and are continuing to monitor non-Bitcoin withdrawals on our platform. Users may experience a slower withdrawal process than normal. Deposits and all Bitcoin withdrawals remain unaffected, and all funds are safe. Sorry for the inconvenience caused and please contact Support if you have any questions.
Posted Nov 11, 2022 - 02:17 UTC
Monitoring
We have implemented a fix for this issue and the wallet page is now working as usual. We will continue to monitor the issue and we remind our users that all funds have remained safe at all times. If you experience any further issues, please contact Support.
Posted Nov 11, 2022 - 00:47 UTC
Investigating
We are investigating an issue that is preventing user access to our 'wallets' page on web. Deposits & withdrawals are being queued, too. The view of the wallets page on our mobile app is not impacted.
We are investigating the root cause and working on implementing a fix and will publish updates as necessary.
We remind our customers that all funds are safe and we apologise for any inconvenience.
If you have any additional questions, please contact Support.
Posted Nov 10, 2022 - 21:37 UTC
This incident affected: BitMEX.com (Web Frontend, Deposits / Withdrawals).