Issue with Index Price Feed and Mark Price Updating
Incident Report for BitMEX
Resolved
We have resolved an issue with the index price feed as of 02:59 UTC. The Mark Price is updating as normal; full trading functionality has resumed. We will be sharing further updates as necessary via Statuspage.
Posted Apr 25, 2022 - 03:06 UTC
Investigating
We are investigating an issue with the index price feed, resulting in the Mark Price not updating since 02:30 UTC. Funds remain safe. As we investigate urgently we will be sharing regular updates via StatusPage.
Posted Apr 25, 2022 - 02:53 UTC
This incident affected: BitMEX.com (Trading Engine).