Versions 3.0.3 and 3.0.4 of the BitMEX mobile app have an issue where the order list only shows the last order placed in the trade screen. We advise users to exercise caution while using these versions. A new version, 3.1.0 which includes the fix is now available through Google Play store, Apple Appstore, Apple Testflight and as an APK download through bitmex.com/mobile.
Posted Jun 03, 2025 - 08:50 UTC
Monitoring
Versions 3.0.3 and 3.0.4 of the BitMEX mobile app have an issue where the order list only shows the last order placed in the trade screen. We advise users to exercise caution while using these versions. A new version, 3.1.0 which includes the fix is now available through Google Play store and Apple Testflight and as an APK download through bitmex.com/mobile. Apple Appstore release is pending their review process.
Posted Jun 03, 2025 - 01:18 UTC
Identified
Versions 3.0.3 and 3.0.4 of the BitMEX mobile app has an issue where the order list only shows the last order placed in the trade screen. We advise users to exercise caution while using this version and will update this status when a fix has been released.