Withdrawals Fees calculation incorrect
Incident Report for BitMEX
Resolved
This incident has been resolved and all our systems are working as usual.

We apologise for any inconvenience caused and we remind our users that all funds have remained safe at all times.

Please contact Support with any further questions.
Posted Aug 14, 2023 - 08:36 UTC
Monitoring
We have implemented a fix for this issue and the fee display for withdrawals is now working as usual.

We will continue to monitor the issue and we remind our users that all funds have remained safe at all times.
If you experience any further issues, please contact Support: https://www.bitmex.com/contact
Posted Aug 14, 2023 - 08:10 UTC
Investigating
We have identified an issue that is affecting the fee display for withdrawals.

The withdrawal is processing as usual however the fees displayed may be incorrect.

We are working on implementing a fix and will publish updates as necessary.

We remind our customers that all funds are safe and we apologise for any inconvenience. If you have any additional questions, please contact Support here: https://www.bitmex.com/contact
Posted Aug 14, 2023 - 06:41 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).