Issue with processing withdrawals
Incident Report for BitMEX
Resolved
We have solved the issue that was impacting withdrawals on our platform and all our systems are working normally now. We remind our users that funds have remained safe at all times. If you are experiencing any further issues, please contact our Support team.
Posted Oct 14, 2022 - 08:11 UTC
Identified
We have identified the cause that is preventing withdrawals from being processed and we are already implementing a fix. We will post updates as necessary and we remind our users that funds are safe at all times. If you have any further questions, you can contact Support.
Posted Oct 14, 2022 - 07:56 UTC
Investigating
We have detected an issue that is preventing withdrawals from being processed on a timely manner. We are investigating the root cause and will implement a fix as soon as possible. We remind our users that all funds are safe. If you have any further questions, you can contact Support.
Posted Oct 14, 2022 - 07:40 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).