Issues with geo-located KYC process
Incident Report for BitMEX
Resolved
We have resolved the incident, all features are working normally. We apologise for any inconvenience and remind customers that all funds have been safe at all times.
Posted Aug 31, 2022 - 13:52 UTC
Investigating
We have identified a problem related with our KYC process that is affecting some users being unable to KYC using their geo location feature. We are investigating what is causing this and will implement a fix as soon as possible. All funds remain safe, we will post updates as necessary.

We recommend users to upload a proof of address instead to verify their accounts.
Posted Aug 31, 2022 - 13:09 UTC
This incident affected: BitMEX.com (Identity Verifications).