Processing of withdrawals delayed
Incident Report for BitMEX
Resolved
This incident has been resolved, and all our systems are working as usual.

Pending withdrawals have been processed, however, selected withdrawal confirmation requests may have expired, and you need to re-initiate the withdrawal via www.bitmex.com/wallet.

We apologise for any inconvenience caused and remind our users that all funds have always remained safe.
Please contact Support with any further questions.
Posted May 19, 2023 - 02:54 UTC
Identified
We are experiencing delays with the processing of withdrawals across all networks due to issues with the transaction infrastructure.

All funds are safe, and the issue has been identified. A fix is being implemented.

For more information, please contact support@bitmex.com
Posted May 19, 2023 - 01:31 UTC
This incident affected: BitMEX.com (Deposits / Withdrawals).