BitMEX Trollbox is temporarily unavailable
Incident Report for BitMEX
Resolved
This incident has been resolved, and all our systems are working as usual.

We apologise for any inconvenience caused and we remind our users that all funds have remained safe at all times. Please contact Support with any further questions.
Posted Jun 20, 2023 - 05:14 UTC
Monitoring
We have implemented a fix, and the BitMEX Trollbox is now working as usual.

We will continue to monitor the issue, and remind our users that all funds have remained safe at all times. If you experience any further issues, please contact Support.
Posted Jun 20, 2023 - 04:21 UTC
Investigating
We have identified an issue that is affecting the availability of the BitMEX Trollbox.

We are working on implementing a fix and will publish updates as necessary.

We remind our customers that all funds are safe, and we apologise for any inconvenience.
If you have any additional questions, please contact Support.
Posted Jun 20, 2023 - 04:13 UTC
This incident affected: BitMEX.com (Web Frontend).