Trading Engine Interruption
Incident Report for BitMEX
Postmortem

On 19 February at 05:31 UTC, BitMEX experienced a minor outage for approximately 1 minute whereby all trading engine operations were suspended.

This issue occurred due to a sustained period of data transfers between the internal market data distribution components. This was part of a regularly scheduled update to improve the overall resiliency of the platform. The root cause has been identified and a fix via internal processes has been put in place to prevent a recurrence. Additionally, we are continuing to re-work our market data distribution architecture to eliminate any potential impact to the trading engine in such a scenario.

Posted Jan 15, 2020 - 00:26 UTC

Resolved
The issue has been resolved. We apologise for any inconvenience this may be causing. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Feb 19, 2019 - 05:32 UTC
Investigating
We have observed an interruption of the trading engine. We apologise for any inconvenience this may be causing. We are looking into the cause of this issue, and will be sharing an update as soon as possible. If you have any further questions, please contact us via https://www.bitmex.com/app/support/contact.
Posted Feb 19, 2019 - 05:31 UTC
This incident affected: BitMEX.com (Trading Engine).