Trading page loading slower than normally
Incident Report for BitMEX
Resolved
The network issue with our cloud provider has been resolved now and the BitMEX trading website is working normally. We apologise for any inconvenience caused; please contact Support for any further questions.
Posted Nov 02, 2022 - 16:36 UTC
Investigating
We have identified an issue causing delays on the time it usually takes users to load the BitMEX trading webpage. Trading is unaffected and all funds remain safe. Our team is working on the issue and will implement a fix as needed. We are sorry for any inconvenience, please contact Support if you have any further questions.
Posted Nov 02, 2022 - 13:21 UTC
This incident affected: BitMEX.com (Web Frontend).