Issue Affecting KYC Processing
Incident Report for BitMEX
Resolved
This incident has been resolved. If you have any questions, get in touch with Support.
Posted Feb 21, 2023 - 04:16 UTC
Monitoring
A fix has been implemented at approximately 03:50 UTC. We are monitoring the results, and will provide further updates as soon as possible. All funds are safe; if you have any questions, please contact Support.
Posted Feb 21, 2023 - 03:55 UTC
Investigating
We’re aware of an issue impacting part of the KYC process on BitMEX (in particular - uploading documents during the KYC process) and are investigating urgently. A further update will be provided here as soon as possible. All funds are safe and we apologise for any inconvenience caused. If you have any questions in the meantime, please contact Support.
Posted Feb 21, 2023 - 03:23 UTC
This incident affected: BitMEX.com (Web Frontend).