Elevated error rates placing trades

Incident Report for BitMEX

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 11:42 UTC

Monitoring

We have received reports of elevated error rates when placing trades. We have identified a potential cause for this and remediated it, trading should now be operating as normal and error rates have stabilised to normal levels.
Posted Mar 27, 2025 - 07:46 UTC
This incident affected: BitMEX.com (REST API).