At this time, e-mails are now being delivered instantly as expected. Following the data center outage from our e-mail provider this morning, e-mails sent between approximately 12:00PM UTC - 12:15PM UTC are currently still queued for delivery, our provider will be working to get those delayed messages delivered as quickly as possible - there is no other backlog. We thank you for your patience.
Resolved
At this time, e-mails are now being delivered instantly as expected. Following the data center outage from our e-mail provider this morning, e-mails sent between approximately 12:00PM UTC - 12:15PM UTC are currently still queued for delivery, our provider will be working to get those delayed messages delivered as quickly as possible - there is no other backlog. We thank you for your patience.
Identified
Starting around 11am UTC, our e-mail delivery provider has been experiencing some disruption, in turn causing some e-mails to be delayed. We are in active discussions with our provider and will update our page accordingly. We apologise for any inconvenience this may be causing.