Resolved
This issue has been successfully resolved. We remind our users that funds remained safe at all times and apologise for any inconvenience.
Monitoring
A fix has been implemented and we are monitoring the results.
Identified
We have identified a problem that is causing delays on processing deposits and withdrawals of ETH/ERC-20 and TRX/TRON20. All funds remain safe and we are currently working on a fix. We will post updates as necessary and apologise for any inconvenience.