Resolved
The withdrawal backlog has been cleared and systems are operating as expected.
Monitoring
We have implemented a fix and are processing withdrawals.
We apologise for any inconvenience caused.
Identified
We have identified the issue and are working on a fix.
Investigating
We are investigating an issue causing a delay to withdrawals. Deposits are currently unaffected.
We ensure users that funds are safe, and withdrawals will be processed as soon as the issue is identified and resolved.
If you have any further questions please reach out to customer support.