Monitoring
All systems operating normally - we are continuing to monitor
Monitoring
We have identified an issue where some users would have seen incorrect information or balances reflected in their account UI.
Fund Security: Please rest assured that all user funds are completely safe and secure. This is strictly a frontend display issue.
Fix deployed: Our engineering team has identified the root cause and restored the correct UI data.