Resolved
The fix has been implemented and withdrawals are now flowing as expected.
Identified
We have cleared the backlog of withdrawals and continue to work on a permanent fix.
Identified
We have identified an issue preventing the processing of withdrawals to a completed state, and are actively working on a fix. We would like to assure you that all funds remain safe.